Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12078 closed Bug (invalid)

form select option tags are split into multiples

Reported by: Don Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 4.4.0
Keywords: Cc:

Description

When switching to source mode from WYSIWYG mode, the editor splits option tags into multiples, mangling the form being edited. This happens in all browsers (I tested IE11, Chrome 35, Firefox 29)

For instance, the form select here: <select name="mobile_service_provider"> <option value="ATT">AT&amp;T</option> <option value="Verizon">Verizon</option> <option value="Sprint">Sprint</option> <option value="T-Mobile">T-Mobile</option> <option value="Simple Mobile">Simple Mobile</option> <option value="Virgin">Virgin Mobile</option> <option value="Other">Other</option> </select>

Becomes mangled like this (4 new options, split off from intended): <select name="mobile_service_provider"> <option value="ATT">AT&amp;T</option> <option value="Verizon">Verizon</option> <option value="Sprint">Sprint</option> <option value="T-Mobile">T-Mobile</option> <option value="Simple Mobile">Simple</option> <option value="Simple Mobile"></option> <option value="Simple Mobile">Mobile</option> <option value="Virgin">Virgin</option> <option value="Virgin"></option> <option value="Virgin">Mobile</option> <option value="Other">Other</option> </select>

Change History (5)

comment:1 Changed 5 years ago by Jakub Ś

Keywords: form select option tag removed
Status: newpending
Version: 4.4.1

I have just checked CKEditor demo page, latest nightly http://nightly.ckeditor.com/14-06-09-06-05/full/samples/replacebycode.html and my local CKEditor. None shown error you describe.

Most likely this is caused by some third-party plugin not created by CKSource. Please disable your custom plugins and recheck. You can then enable custom plugins one by one to find out which one is causing this. Finally if plugin is found, such error should be reported to plugin author.

Another option is that some third-party script in your application is conflicting with CKEditor and causing such behaviour. Please download fresh CKEditor (I recommend full package), put it on server as standalone app and then check. If problem doesn't occur, you can start disabling third-party scripts one by one in your app and see when issue is gone.

Don't forget to clear browsers cache (this isn't Ctrl+F5) before each step .

comment:2 Changed 5 years ago by Don

I have isolated the problem. In fact it is not the form plugin, but the SCAYT plugin. When SCAYT is enabled, multi-word select options are split into many. It's kind of fun, actually, as you get to watch the option being split into many.

But it's a disaster for the form being authored.

comment:3 Changed 5 years ago by Jakub Ś

Problem can be reproduced from CKEditor 4.4.

I have reported it to SCAYT team here: https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/73.

Last edited 5 years ago by Jakub Ś (previous) (diff)

comment:4 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Version: 4.4.0

This problem is specific to SCYT thus i'm closing this issue as invalid.

comment:5 Changed 4 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy