Opened 5 years ago

Closed 5 years ago

#12104 closed Bug (fixed)

[FF30+] Regression in editor/focus test

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone: CKEditor 4.4.6
Component: General Version:
Keywords: Firefox Cc:

Description

http://tests.ckeditor.dev:1030/tests/core/editor/focus

Caused by an ugly FF bug. After framed editor body is changed, FF yields body to be the active element, selection to be anchored in it, but you can't see it and editor and when focus is moved to other focusable element, blur is not fired.

For now I'm adding test to regressions. It's not a huge problem in framed editor. But we need to trim this case down and report it on bugzilla.

Change History (8)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Added test to regressions: git:d5410f11.

comment:2 Changed 5 years ago by Olek Nowodziński

Also two tests in http://tests.ckeditor.dev:1030/tests/plugins/widget/widgetselection fail because of that.

A funny fact 1: if address bar is focused, a different set of tests will fail.

A funny fact 2: once updated regressions, two different tests failed.

More regressions added in git:c309aee.

comment:3 Changed 5 years ago by Piotrek Koszuliński

I honestly don't want to think about working on this. Browsers' focus handling implementations are truly the worst.

comment:4 Changed 5 years ago by Jakub Ś

Status: newconfirmed

comment:5 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.3CKEditor 4.4.4

The 4.4.3 milestone was shortened, so the remaining tickets must be postponed.

comment:6 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.4CKEditor 4.4.5

comment:7 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.5CKEditor 4.4.6

comment:8 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed by #12630.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy