Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12105 closed Bug (invalid)

Image alignment - bulleted lists do not wrap correctly.

Reported by: Zoltan Koszegi Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Oracle Cc:

Description

If a bulleted list wraps to the right around a left-aligned image, the bullets do not move with the list. Instead, the bullets appear left aligned on top of the image, and the list text wraps to the right of the image.

STR (I used full featured demo page with IE11)

  1. Clear the page and insert a larger graphic.
  2. Create a bulleted list below the image.
  3. Select the image and apply a left-alignment.
  4. The bullet text wraps to the right of the image, but the bullets appear at the left margin on top of the image.

Please see the attached image.

Attachments (1)

Snap1.jpg (26.0 KB) - added by Zoltan Koszegi 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by Zoltan Koszegi

Attachment: Snap1.jpg added

comment:1 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.4.1

This is Browser issue which can be fixed with appropriate CSS rules.
Please see: http://stackoverflow.com/questions/710158/why-do-my-list-item-bullets-overlap-floating-elements

What you can do is experiment with overflow:hidden or below rules.

ul {
    list-style: outside disc; /* or inside - depends what one likes*/
    margin-left: 1em;
}
ul li {
    position: relative;
    left: 1em;
    padding-right: 1em;    
}​

comment:2 Changed 5 years ago by Piotrek Koszuliński

Well, it's not a browser issue - it's a CSS's default behaviour. One may not like it, but it's not a bug definitely. And it can be "fixed" by tweaking CSS.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy