Opened 4 years ago

Closed 4 years ago

#12111 closed Bug (fixed)

Image attributes read incorrectly in specific selection context

Reported by: Marek Lewandowski Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.4.4
Component: General Version: 4.4.1
Keywords: Cc:

Description (last modified by Olek Nowodziński)

Checked only on IE10, but this issue might be also present in other IE versions

  1. open any sample with CKEditor and image plugin (i.e. samples/replacebyclass.html)
  2. use following source
    <p>Text with <a href="http://ckeditor.com">li<img alt="" src="assets/sample.jpg" style="height:60px; width:48px" />nk</a> and image .</p>
    
  3. go back to wysiwyg mode
  4. double click image to check its properties

Expected result:
Properties like image source link, height and width should be predefined in text inputs.

Current result:
Properties are missing.

additional info:

  1. Desired information are available in dialog after Right Click / Image Properties.
  2. Seems to work OK in 4.4.0

Change History (14)

comment:1 Changed 4 years ago by Marek Lewandowski

Summary: [IE] Image attribute not readed correctly[IE10] Image attribute not readed correctly

comment:2 Changed 4 years ago by Marek Lewandowski

Description: modified (diff)

comment:3 Changed 4 years ago by Marek Lewandowski

Same goes for other kind of stuff like inputs etc.

comment:4 Changed 4 years ago by Olek Nowodziński

I reproduced it in Chrome and FF. It seems that the reason why it happens is that the link gets selected on double click but it's Image dialog which is opened.

comment:5 Changed 4 years ago by Olek Nowodziński

Summary: [IE10] Image attribute not readed correctlyImage attributes read incorrectly in specific selection context

comment:6 Changed 4 years ago by Olek Nowodziński

Status: newconfirmed

comment:7 Changed 4 years ago by Marek Lewandowski

Description: modified (diff)

comment:8 Changed 4 years ago by Olek Nowodziński

Description: modified (diff)

comment:9 Changed 4 years ago by Olek Nowodziński

First bad commit git:33822dd4ad232

comment:10 Changed 4 years ago by Olek Nowodziński

Milestone: CKEditor 4.4.3

comment:11 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.3CKEditor 4.4.4

The 4.4.3 milestone was shortened, so the remaining tickets must be postponed.

comment:12 Changed 4 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:13 Changed 4 years ago by Marek Lewandowski

Status: assignedreview

I had no good idea for the test placement, since it's an integration test for image + link plugin, and it tests very particular dependency. At the end I've put it to ticket tests.

Pushed to t/12111 at dev.

comment:14 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Good job. Though, I had to use the %BASE_PATH% placeholder to generate src for image which will not give 404s and fix args order in one assert.

Fixed on master with git:8f4baa9.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy