Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12136 closed Bug (wontfix)

Some formatting options not working on inline widgets

Reported by: Tsvetelin Novkirishki Owned by:
Priority: Normal Milestone:
Component: UI : Widgets Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Descriptive summary: Underline and Strike through are not working when applied on an inline widget. By CSS specs, the underline does not affect inline blocks (.cke_widget_inline is inline-block) inside the element for which text-decoration: underline or line-through has been set. Partial solution is to make CSS selector like:

s .cke_widget_inline
{
  text-decoration: underline;
}

It's partial, because the user cannot do both underline and strike through at the same time.

Steps to reproduce:

  1. Insert some inline widget
  2. Underline it and you'll see nothing will happen
  3. Take a not at the path - it shows the U tag, but it's not visible to the user

Browser and OS: Chrome and Firefox under both Windows and Linux

Change History (2)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Description: modified (diff)
Version: 4.4.3 (GitHub - master)4.3 Beta

comment:2 Changed 5 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: newclosed

We do not control page's styling (we only propose contents.css) and cannot hardcode such styles in the code (because <u> and <s> default styles can be changed by page's author). This is CSS'es problem which only page authors can solve. Note that it may be possible to style all combinations of underline and strike-through. Just create 4 selectors:

s widget {}
u widget
u s widget, s u widget {}
Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy