Opened 5 years ago

Closed 5 years ago

#12221 closed Task (duplicate)

[Blink] Failing test_enlarge_element12 test

Reported by: Marek Lewandowski Owned by: Piotrek Koszuliński
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by Marek Lewandowski)

In Chromium nightly version I see that test_enlarge_element12 test fails.

I can confirm that this issue got also into Google Chrome Canary channel.

The issue is with selection after calling enlarge.

Expected selection:

<p>Test [<i><b></b>Enlarge</i>]</p>

Actual selection (only in chrome):

<p>Test <i><b></b>[Enlarge]</i></p>

UA versions:

  • Chromium: Chrome/38.0.2098.0
  • Chrome Canary: Chrome/38.0.2097.0

Change History (6)

comment:1 Changed 5 years ago by Marek Lewandowski

Description: modified (diff)
Owner: set to Marek Lewandowski
Status: newassigned

comment:2 Changed 5 years ago by Marek Lewandowski

Milestone: CKEditor 4.4.4

The trouble maker was this little guy.

Chrome has now a bug with returning valid offsetWidth property. I created a ticket in Chromium tracker.

Lets wait for their reaction, since that's not our bug here.

comment:3 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.4CKEditor 4.4.5

Still waiting for Chrome team to react.

comment:4 Changed 5 years ago by Piotrek Koszuliński

So we waited and Chrome bug made from Chrome Canary to Chrome 37 (Linux) which I have currently installed. We need to fix the offset check. I remember that we already had this issue on Webkit - it was enough to compare offset to 1 instead of 0.

comment:5 Changed 5 years ago by Piotrek Koszuliński

Owner: changed from Marek Lewandowski to Piotrek Koszuliński

comment:6 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.5
Resolution: duplicate
Status: assignedclosed

I'm closing this as duplicate of #11111 - that's the ticket for the same regression introduced few months ago in Safari. Nice, regressions are spreading across code bases ;>.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy