Opened 5 years ago

Closed 5 years ago

#12222 closed Bug (duplicate)

Drag-and-drop image bug in Chrome

Reported by: sailorzhang Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Blink Cc:

Description (last modified by Alan)

Descriptive summary - In Chrome browser, drag-and-drop image does not work if the editor does not already have content. Drag-and-drop an image from other web page causes the whole browser window to load that image.

Steps to reproduce -

  1. In a Chrome browser window A, go to http://www.ckeditor.com/demo.
  2. Click on the editor area, select all content and delete it. (Screenshot#1)
  3. Open another Chrome window B, go to any page that has images, e.g. http://www.rolia.net (Screenshot#2)
  4. Drag an image from B, drop in at the lower right area of the CKEditor in A.
  5. Expected: the image is added in the CKEditor; Actual: The whole window of A loads the image. (Screenshot#3)
  6. If there is already content in the editor, the operator is normal. (Screenshot#4)

Browser and OS - Current version of Chrome browser, tested in both OS X and Windows 7.

Screenshot -

Attachments (4)

CKEditor_DragNDrop_Bug_Screen1.png (97.0 KB) - added by sailorzhang 5 years ago.
CKEditor_DragNDrop_Bug_Screen2.png (692.5 KB) - added by sailorzhang 5 years ago.
CKEditor_DragNDrop_Bug_Screen3.png (645.8 KB) - added by sailorzhang 5 years ago.
CKEditor_DragNDrop_Bug_Screen4.png (456.9 KB) - added by sailorzhang 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by sailorzhang

Changed 5 years ago by sailorzhang

Changed 5 years ago by sailorzhang

Changed 5 years ago by sailorzhang

comment:1 Changed 5 years ago by Alan

Keywords: Blink added
Status: newconfirmed
Version: 4.4.34.0
Last edited 5 years ago by Alan (previous) (diff)

comment:2 Changed 5 years ago by Alan

Description: modified (diff)

comment:3 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This is in fact duplicate of #10169.

What was missed here is that Drag and Drop works but only if you drop image in the first line where cursor blinks. It is easy missing that.

Source of this problem is very small content area which also results in native browser menu being shown on right click when you click below first line.

To work around this problem please refer to 10169#comment:5

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy