Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12298 closed Bug (fixed)

IE11+Compat: Click bellow body puts selection at first line

Reported by: Frederico Caldeira Knabben Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.4.4
Component: Core : Selection Version: 4.0 Beta
Keywords: IE11 Cc:

Description

With IE11 in compatibility mode:

  1. Load this HTML:
<p>Line 1</p>
<p>Line 2</p>
  1. Back to WYSIWYG mode, put the focus outside the editor.
  2. Click the empty area bellow the text in the editor (in other words, outside <body>)

In all browsers, including IE11, the selection goes to the end of "Line 2". In IE11+Compat, it goes to the beginning of "Line 1".

Clicking and dragging in that same empty space will enlarge the selection always at "Line 1" as well.

Change History (8)

comment:1 Changed 4 years ago by Frederico Caldeira Knabben

This should be fixed by some magic we have in selection.js. For some reason it is not working for IE11+Compat.

comment:2 Changed 4 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: newassigned

comment:3 Changed 4 years ago by Jakub Ś

CKEditor supports IE11 from version 4.3 but in compatibility mode this problem can be reproduced from CKEditor 4.0. In CKEditor 4.0 beta it wasn't possible to click in empty area and gain focus.

If we are going to fix this issue in CKE 3.x then this issue can be reproduced from CKEditor 3.1 (works fine in CKE 3.0 - 3.0.2)

One final note: I have got cursor blinking at the beginning in both modes IE11 and IE11 Compatibility mode.

comment:4 Changed 4 years ago by Frederico Caldeira Knabben

An additional note... the click must be done at the empty are bellow the text... I mean, the Y coordinate of the click must match the text. If it is at the bottom but also at the right, the selection goes to the beginning of "Line 2" (still not the end if it).

comment:5 Changed 4 years ago by Frederico Caldeira Knabben

In IE11 Standards, the selection is restored to its previous place. So if was at the end, it'll be back to the end. The same thing when it was in the middle of the text.

In IE11 Compat this is different. It goes always to line 1. That's because the old IE hack is applied to it.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Status: assignedreview
Version: 4.5.0 (GitHub - major)4.0 Beta

I pushed branch:t/12298 with a simple fix. It turned out that on IE11 in compat mode a non-standard MouseEvent.x/y properties were behaving very oddly and thus the fix didn't work. I changed them to standard MouseEvent.clientX/Y, which works fine on IE8QM and IE9QM and IE8CM.

comment:7 Changed 4 years ago by Marek Lewandowski

Resolution: fixed
Status: reviewclosed

I went through IE8-IE11 in diffrent modes, and it seems to be working well.

Fixed with git:f9c98f43a0 (merged to master) at dev.

comment:8 Changed 4 years ago by Marek Lewandowski

Milestone: CKEditor 4.4.4
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy