Opened 5 years ago

Last modified 5 years ago

#12297 confirmed Bug

When searching a text, the matched chunk does highlight, but does not scroll to it's position in the area

Reported by: Iliyan Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Open full featured demo http://ckeditor.com/demo#full Paste the dummy "Lorem Ipsum..." text several times in order to have scrollbar in the editor. Open "Find" window and try to search "Lorem" word. The scrolling to the word is not correct in all matches. Sometimes the whole page is scrolled.

Change History (5)

comment:1 Changed 5 years ago by Jakub Ś

Status: newpending

In which browser and operating system you get this?

Could you provide screen cast (e.g. jing video) for this issue? I have checked every browser and could not reproduce this problem. Most likely I have missed some step so video will be helpful.

comment:2 Changed 5 years ago by Kiroff

Hi due to file size limitation I'm not able to upload a screen-capture. Please, check if the following video is good enough: https://www.youtube.com/watch?v=_ZaNEJn0AAU The video is captured on Google Chrome 36.0.1985.143, but it is confirmed to be consistent on Firefox 31.0 as well. Could change IEs if needed.

comment:3 Changed 5 years ago by Piotrek Koszuliński

Status: pendingconfirmed

Thanks for screencast. I can confirm this issue. However, it only occurs when text is in one looong paragraph. Viewport was correctly scrolled when I split it.

comment:4 in reply to:  3 Changed 5 years ago by Kiroff

Replying to Reinmar:

Thanks for screencast. I can confirm this issue. However, it only occurs when text is in one looong paragraph. Viewport was correctly scrolled when I split it.

Yes, we can confirm that as well.

comment:5 Changed 5 years ago by Jakub Ś

Problem can be reproduced from CKEditor 4.0 (works fine in beta).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy