Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#12315 closed Bug (fixed)

Mention that disabling auto paragraphing is highly unrecommended; mark as deprecated

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone: CKEditor 4.4.5
Component: General Version:
Keywords: Cc:

Change History (8)

comment:1 Changed 4 years ago by Jakub Ś

Status: newpending

It is already mentioned in documentation - http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-autoParagraph.

Do we need anything more?

comment:2 Changed 4 years ago by Piotrek Koszuliński

Yes. We only mention that it may lead to accessibility issues. This is not strong enough.

comment:3 Changed 4 years ago by Jakub Ś

Status: pendingconfirmed

comment:4 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

We decided to mark this option as deprecated. It was introduced without strong reasons and cannot be handled in satisfying way without significant effort, since its affects multiple features (from data processing, to backspace/delete handling, styles and formats).

Fixed on master with git:6ca8f3f and https://github.com/ckeditor/ckeditor-docs/commit/beb6213bf76e27a6c22377595a0b1f1f78d9084e.

Last edited 4 years ago by Piotrek Koszuliński (previous) (diff)

comment:5 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)
Summary: Mention that disabling auto paragraphing is highly unrecommendedMention that disabling auto paragraphing is highly unrecommended; mark as deprecated

comment:6 Changed 3 years ago by Mike W

I just want to say that there are still use cases for turning off autoparagraph. We have a scenario where we use razor syntax and having the autoparagraph could cause issues.

comment:7 Changed 3 years ago by Piotrek Koszuliński

But that means that you are overusing CKEditor. It's a text editor, not a code editor. I understand that it's easy to put some non-HTML markup into the editor, but that does not mean it's the right way of doing things.

BTW. A correct implementation here would be to write a widgets for the parts of the markup that are not HTML. They would need to be decorated before the HTML is parsed by CKEditor (so in high prior editor#toHtml listener) and then turned into widgets.

comment:8 Changed 3 years ago by Mike W

Reinmar --

You have some valid points and I appreciate the good ideas and suggestions. I didn't even realize there were code editors for the web.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy