Opened 5 years ago

Closed 5 years ago

#12321 closed Bug (fixed)

[IE] pressing backspace / delete does not fire editor#change

Reported by: Marek Lewandowski Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.4.4
Component: Core : Undo & Redo Version: 4.4.4
Keywords: IE Cc:

Description

  1. open any sample with CKEditor (i.e. samples/replacebyclass.html)
  2. add an change listener using console:
    CKEDITOR.instances.editor1.on( 'change', function() { console.log( 'change event' ); } );
    
  3. click somewhere in the middle of the text
  4. press backspace

Expected result:
Change event should be fired / console log should appear.

Current result:
Change event is not fired.

additional info:

  1. tested in IE8 and IE9

Change History (7)

comment:1 Changed 5 years ago by Piotrek Koszuliński

If it's confirmed please assign it to 4.4.5.

comment:2 Changed 5 years ago by Jakub Ś

Keywords: IE added
Milestone: CKEditor 4.4.5
Status: newconfirmed
Version: 4.4.4 (GitHub - master)

Reproducible in IE8-11.

It is confirmed and what is more it seems to work in CKEditor 4.4.3 but not on master so it looks like regression.

@Reinmar are you sure about 4.4.5?

comment:3 Changed 5 years ago by Piotrek Koszuliński

Yes. It's too late for including it in 4.4.4.

comment:4 Changed 5 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedreview

Pushed to t/12321 at dev.

Turns out that undoManager#type was not called for IEs when it should. I've also fixed invalid comment, since IE is not firing keypress for delete/backspace.

comment:5 Changed 5 years ago by Olek Nowodziński

Status: reviewreview_passed

I'm OK with the fix, it looks fine.

Please separate changes in tests from the rest of code before merging into master.

comment:6 Changed 5 years ago by Piotrek Koszuliński

Please separate changes in tests from the rest of code before merging into master.

That's not necessary, unless there was some refactorisation. We accept fix+tests in one commit.

comment:7 Changed 5 years ago by Marek Lewandowski

Milestone: CKEditor 4.4.5CKEditor 4.4.4
Resolution: fixed
Status: review_passedclosed

Changed milestone to 4.4.4.

Fixed with git:67f620b8c2 (merged to master) at dev.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy