Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#12337 closed Bug (fixed)

[Blink][IE] Restoring first undo might contain unexpected selection.

Reported by: Marek Lewandowski Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version: 4.4.4
Keywords: Cc:

Description

This issue has a slightly diffrent outcome in IE / Blink but has the same steps (and problem source I guess).

  1. Open any CKEditor inlineall.html sample.
  2. Hit tab key 4 times (to get focus to the right-hand side editor).
  3. Press single printable char key, eg. a
  4. Press ctrl + z to perform undo

Expected result:
Caret should be collapsed right before first word that's "Lorem"

Current result:
Opera: Caret lands before the first paragraph. So further typing will create new paragraph.

In case of IE caret lands more-less in the middle of text.

additional info:

  1. This is an regression introduced in 4.4.4.
  2. You're not able to reproduce this with mouse.
  3. You're not able to reproduce it when you'll press any printable or navigation key prior TC. So you're able to reproduce issue only in that particular sequence.
  4. Experienced in Opera, Chrome, IE8

Change History (3)

comment:1 Changed 5 years ago by Piotrek Koszuliński

This is also more general issue, that selection is not being normalised to a correct position if browser placed it in incorrect place.

But since in 4.4.4 thing got a little bit worse, this regression needs a special attention.

comment:2 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: newclosed

This issue is no logner reproducible. It has been fixed in CKEditor 4.4.6.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Yep - you may remember http://dev.ckeditor.com/ticket/12944#comment:4 - as I explained there, that patch in 4.4.6 was really valuable.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy