Opened 12 years ago

Closed 12 years ago

#1234 closed Bug (fixed)

Backspace is broken

Reported by: Scott McNaught Owned by:
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: UI : Enter Key Version: SVN (FCKeditor) - Retired
Keywords: Cc:

Description

To replicate:

Source: <p>Paragraph 1</p> <p>&lt;-- Press backspace</p>

In the second line at the start of the paragraph, press the backspace key. The second paragraph is deleted.

It appears to fail in

FCKEnterKey.prototype._ExecuteBackspace = function( range, previous, currentBlock )

The "previous" variable is the element <p>Paragraph 1</p> as expected. The "currentBlock" is <p>&lt;-- Press backspace</p> as expected.

However not sure on the technicalities of this, but for some reason you do

Remove the current block. FCKDomTools.RemoveNode( currentBlock ) ;

Which appears to delete the whole second paragraph.

Attachments (1)

nullptr.png (87.7 KB) - added by Scott McNaught 12 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 12 years ago by Scott McNaught

Also if the currentBlock is an empty <p>, theres a null pointer dereference at line 65 of fckdomrange.js.

Maybe the problem is in fckdomrange.js.

See attachment for debug info.

Changed 12 years ago by Scott McNaught

Attachment: nullptr.png added

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Component: GeneralUI : Enter Key
Milestone: FCKeditor 2.5
Resolution: fixed
Status: newclosed
Summary: Backspace Bug in SVN fckenterkey.js (probably line 249)Backspace is broken
Version: SVN

Fixed with [815].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy