Opened 11 years ago

Closed 11 years ago

#1235 closed Bug (fixed)

Bogux BR is excessively removed when joining paragraphs

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: UI : Enter Key Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Firefox Cc:

Description

Steps to Reproduce

  1. Load sample01.html;
  2. Enable "Show Blocks" to make things easier to see;
  3. At the end of the paragraph, hit Shift+Enter;
  4. Now hit Enter for a new paragraph;
  5. Hit backspace.

The second paragraph will be correctly removed, but the cursor will be blinking in the wrong place. The line space in the first paragraph will be removed too.

The problem is that the ending paragraph doesn't have the bogus BR anymore, so it doesn't get expanded.

Change History (1)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [817].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy