Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12367 closed Bug (invalid)

Bold, Italic, Underline, Strike, SubScript, SuperScript buttons don't work in Firefox

Reported by: dan turcu Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version:
Keywords: Cc:

Description

When I press this buttons nothing happens, they don't get selected as usual and also the changes are not reflected in the text selected.

So far I found only one place(only in an Email) where it happens, and only in Firefox.

Attachments (3)

bad.html (5.3 KB) - added by dan turcu 5 years ago.
2014-09-03_1553.swf (2.8 MB) - added by Jakub Ś 5 years ago.
steps_to_reproduce.swf (2.9 MB) - added by Jakub Ś 5 years ago.

Change History (13)

comment:1 Changed 5 years ago by Jakub Ś

Status: newpending
Version: 4.4.3

I can't confirm that. I have checked few emails and wasn't able to reproduce this issue.

  1. Can this issue be reproduced on demo page (http://ckeditor.com/demo)?
  2. Could you send us screen-cast for this issue? Perhaps there is something I have missed.
  3. Are you using any third-party plugins or scripts that might influence this behaviour?

comment:2 Changed 5 years ago by dan turcu

No , it cannot be reproduced on the demo page. Yes, I am using plugins developed by me, but I don't think that they might influence this behaviour. And I get this error in the javascript debug console : TypeError: c[g].word is undefined - ckscayt.js 36

And if I disable scayt I don't get this error anymore.

comment:3 Changed 5 years ago by dan turcu

I'm using firefox 31.0

comment:4 Changed 5 years ago by dan turcu

My opinion it's that scayt checks doesn't need to be triggered when this buttons are clicked because they don't have nothing to do with language.

comment:5 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I have checked this issue with scayt turned on/off and still can't reproduce this problem.

If it was possible to reproduce this problem in Demo page or default CKEditor (e.g. default full package freshly downloaded from our website) with scayt turned on, I would agree that CKEditor (or SCAYT) might have something to do here. This issue is however not reproducible in default editor but only in your instance with third-party plugins.

My guess is that your plugins not necessarily conflict with CKEditor but they may conflict with SCAYT. The only thing I can recommend is trying same scenario without plugins and if there are no errors, please enable your plugins one by one to see which one is causing problems.

I'm closing this issue as invalid as I don't see any CKEditor issue here. You are however welcome to investigate this problem further comment in this ticket if you are convinced this is editor fault.

Changed 5 years ago by dan turcu

Attachment: bad.html added

comment:6 Changed 5 years ago by dan turcu

I succeeded to reproduce this bug in the demo page using Firefox browser, these are the steps :

  1. Enter the demo page, check the source button and delete all the existing code
  2. Copy Paste the html code from the attached file bad.html
  3. Uncheck the source button and try to click one of the Bold Italic Strike buttons

Changed 5 years ago by Jakub Ś

Attachment: 2014-09-03_1553.swf added

comment:7 Changed 5 years ago by Jakub Ś

I have tried your steps but all seem to work fine. Please see attached video.

comment:8 Changed 5 years ago by dan turcu

Sorry, my fault, there is another step: you should enable SCAYT first in the editor.

Changed 5 years ago by Jakub Ś

Attachment: steps_to_reproduce.swf added

comment:9 Changed 5 years ago by Jakub Ś

Thank you for the details. I have reported this issue (https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/79) to SCAYT team because it doesn't happen by default in editor.

Let's keep this ticket closed as this is SCAYT issue.

comment:10 Changed 5 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy