Opened 12 years ago

Closed 7 years ago

#1237 closed Bug (wontfix)

Shift+Enter doens't work at first time in an empty paragraph (IE)

Reported by: Frederico Caldeira Knabben Owned by: Martin Kou
Priority: Normal Milestone:
Component: UI : Enter Key Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Discussion Cc:

Description

Steps to Reproduce

  1. Open sample01.html and enable "Show Blocks";
  2. Hit Enter at the end of the paragraph;
  3. Hit Shift+Enter.

The cursor will make a "quick strange blink", but there will be no visual results.

Switching to source view, the second paragraph will display the correct HTML:

<p><br />
&nbsp;</p>

So it seams that the Shift+Enter itselft is working, but the selection is not being made visible after the <br>.

Change History (11)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5FCKeditor 2.6

I'm my latest tests with the SVN version, I'm having this problem only if "Show Blocks" is enabled. In any case it is not making it impossible to have the <br> as expected, so other than being a rare and unfortunate case, it is also something with a minor consequence. Therefore, postponing.

comment:2 Changed 12 years ago by Martin Kou

#1348 marked as a dup to this ticket.

comment:3 Changed 11 years ago by Martin Kou

IE is so much fun, it screws up the <BR> when any background CSS attribute is applied to the paragraphs. Without the background attribute however (i.e. with the border alone), it would screw up in another funny way in which the <BR> typed would be displayed but not included within the paragraph border.

comment:4 Changed 11 years ago by Martin Kou

If this ticket were to be fixed, I think another way of displaying blocks would need to be invented. Otherwise, this ticket might end up as another wontfix.

comment:5 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [1717]. Click here for more info about our SVN system.

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: closedreopened

Sorry! Not fixed... just worked on the wrong ticket. Please ignore my previous comment.

comment:8 Changed 11 years ago by Martin Kou

Keywords: CantFix added
Resolution: wontfix
Status: reopenedclosed

It seems there's no other way to display and block boundaries and displaying the block type without using the buggy CSS attributes. So there's not much we can do here with just JavaScript and CSS. Closing ticket as wontfix.

comment:9 Changed 10 years ago by Garry Yao

Keywords: Discussion added; CantFix removed
Milestone: FCKeditor 2.6CKEditor 3.x
Resolution: wontfix
Status: closedreopened

Retarget to v3 for further discussion.

comment:10 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:11 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: reopenedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Works in latest CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy