Ticket #1238 (closed New Feature: fixed)

Opened 7 years ago

Last modified 16 months ago

Auto-correct missing semi-colons

Reported by: fredck Owned by:
Priority: Normal Milestone:
Component: Project : CKPackager Version:
Keywords: Cc:

Description

It is happening too often that missing semi-colons comes to break the compressed source produced by FCKpackager. We should find ways to detect those cases, and automatically correct them in the compressed output.

It would be nice to have them reported in the program output too, so we have a chance to fix them in the original source.

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Confirmed added

comment:2 Changed 6 years ago by fredck

Check out chapter 7.9 (Automatic Semicolon Insertion) at the ECMA-262 specifications.

comment:3 Changed 16 months ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to fixed

I think that this issue expired since we use now linter and Google Closure Compiler.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy