Opened 5 years ago

Closed 5 years ago

#12439 closed Bug (duplicate)

"CKEDITOR.ENTER_BR" / "<br /> tags" conflict...

Reported by: Angel Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version:
Keywords: Cc: angelherriv@…

Description

Hello, in my usage of CKEditor I need CKEDITOR.ENTER_BR, but I have a problem:

For some reason CKEditor removes the last <br>

For example, you can open: samples/plugins/enterkey/enterkey.html

Set option: "When Enter is pressed" to: "Break the line with a <BR>"

Remove the content of the editor, and once the page is blank, press enter key, for example, three times.

Then, switch to HTML source view.

You will see three <br /> tags.

Then switch to WYSIWYG view and then to HTML source view again.

Now you will see two <br /> tags (one less).

And so on, until all <br /> tags dissapears.

Regards!

Change History (2)

comment:1 Changed 5 years ago by Angel

I need some kind of workaround for this because this behavior is causing inconsistency between what is editing and the final output.

Thanks in advance ;)

comment:2 Changed 5 years ago by Jakub Ś

Keywords: ENTER_BR br tag remove removed
Resolution: duplicate
Status: newclosed
Version: 4.4.4

I can't confirm this issue for CKEditor 4.4.4 in any browser.

I have checked it and it looks like a duplicate of #11392 which is continuation of #10146. As you can see this is a part of larger issue.

I'm closing this issue as duplicate but if you think this is not it, please provide CKEditor version, browser where is happens and information if you are using any third-party plugins or have made any core code customizations.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy