Opened 4 years ago

Closed 3 years ago

#12440 closed New Feature (fixed)

Configuration option to hide the 'Automatic' option in the color picker

Reported by: Christophe Guillou Owned by: Tade0
Priority: Normal Milestone: CKEditor 4.5.8
Component: General Version: 4.4.4
Keywords: IBM Cc: satya_minnekanti@…, irinauru@…

Description

We would like to be able to hide 'Automatic' from the Colorpicker - would it be possible to define a new config option in CKEditor config to be able to remove it?

Change History (8)

comment:1 Changed 4 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

adding myself to cc

comment:2 Changed 4 years ago by Irina

Cc: irinauru@… added

comment:3 Changed 4 years ago by Jakub Ś

Keywords: MailNext removed
Status: newconfirmed

The code of interest can be found in colorbutton/plugin.js. Below is part of code:

output.push( '<a class="cke_colorauto" _cke_focus=1 hidefocus=true' +
...
'<table role="presentation" cellspacing=0 cellpadding=0 width="100%">' );

Since this part is static HTML string we could split apart (last table element has to be separated from link) this string and put the whole link element into 'if' that is evaluated based on configuration option.

comment:4 Changed 3 years ago by Anna Tomanek

Summary: Config option to hide the 'Automatic' option in the colorpickerConfiguration option to hide the 'Automatic' option in the color picker

comment:5 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.8

comment:6 Changed 3 years ago by Tade0

Owner: set to Tade0
Status: confirmedreview

Cherry-picked changes made previously by k.krzton and m.lewandowski.

Changes pushed to branch:t/12440.

comment:7 Changed 3 years ago by Marek Lewandowski

Status: reviewreview_passed

comment:8 Changed 3 years ago by Marek Lewandowski

Resolution: fixed
Status: review_passedclosed

Fixed with git:7c87fba4af (merged to master).

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy