Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12481 closed Bug (invalid)

MathJax does not handle multiple exponents

Reported by: Marek Lewandowski Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

  1. Open CKEditor MathJax sample. (i.e. samples/plugins/mathjax/mathjax.html)
  2. Doble click any MathJax widget to edit it.
  3. Replace its source with following formula:
    10^1^2
    

Expected result:
The formula should be transformed correctly, as an example go to online encoder and test it there.

Current result:
The MathJax output is broken.

Additional info:

  1. I'm not sure if it's our problem or issue with the external library?
  2. Experienced with Chrome 37
  3. Also reproduced in CKE 4.3.1

Change History (4)

comment:1 Changed 5 years ago by Piotrek Koszuliński

I'm not sure if it's our problem or issue with the external library?

How could this be our issue?

comment:2 Changed 5 years ago by Marek Lewandowski

I recall some issue with ampersand. Also I saw that it's parsed correctly in mentioned online encoder. It might use same library as us, and then it would be our issue.

That is simply sth to investigate.

comment:3 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

@m.lewandowski wanted to have 10 to the power of 12. I have tested this and entered this code 10^{12} . It worked with our plugin. What is more I have then found below description (point 5): http://meta.math.stackexchange.com/questions/5020/mathjax-basic-tutorial-and-quick-reference

It turns out that if you want to insert power having more than one number, you need to put it in curly brackets.

I'm not sure why 10^1^2 works in online builder but the proper syntax is with brackets.

comment:4 Changed 5 years ago by Marek Lewandowski

Sounds fair, curly braces in fact are correct way to go.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy