Opened 5 years ago

Closed 5 years ago

#12488 closed Bug (invalid)

different unit for font size

Reported by: Tim Enright Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version:
Keywords: Cc: enright@…

Description

I am using your editor to create rich text on a crm form. The rich text can then be rendered on a report produced within sql server reporting services (SSRS). SSRS allows for rendering simple html (see the link below).

I noticed an issue when I used your tool to change the font color and a font size. It produced the following html: <p><strong><em><span style="color:red; font-family:arial,sans-serif; font-size:16pt">Chatham&nbsp;is&nbsp;for&nbsp;beach&nbsp;combers&nbsp;and&nbsp;<span style="font-size:24px">fishermen</span>!</span></em></strong></p>

Notice how the first font size is defined in units of pt and the second font size is defined in units of px?

Interestingly, SSRS supports the font size unit of pt but not px. So when I changed the font size of the word fisherman, it did not render correctly.

Not sure if this was intended or a bug and I was hoping there was a way to set ckeeditor so that it always uses pt and not px. Is this possible? Thanks in advance, Tim Enright

http://msdn.microsoft.com/en-us/library/ff519562.aspx

Change History (1)

comment:1 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.4.3

Please see: http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-fontSize_sizes

NOTE: CKEditor doesn't apply 'pt' by default. I believe you have made some customizations thus you get such result.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy