Opened 4 years ago

Closed 4 years ago

#12489 closed Bug (fixed)

Cursor jumps to the end of line in Blink and Webkit

Reported by: Jakub Ś Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.4.6
Component: General Version: 4.4.4
Keywords: Blink Webkit Support Cc:

Description

  1. Go to http://ckeditor.com/demo
  2. Clear the contents of the CKEditor
  3. Type the following:
    1. "random text"
    2. hit Shift+Enter to create a BR tag
    3. type the following on the next line "11111 111111111"
  4. Click somewhere in the "1111 111111" line

Result: cursor jumps to the end of the text.

Problem can be reproduced from CKEditor 4.4.4 in Blink and Webkit.

Change History (6)

comment:1 Changed 4 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 4 years ago by Piotrek Koszuliński

First bad commit is git:13ac023. And that made me curious what's going on there :D.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.6
Owner: set to Piotrek Koszuliński
Status: confirmedassigned

I started debugging this and my initial impression that it must be related to the filling char was right. There's code in the selection.js file that removes the filling char from DOM before snapshot is taken and restore it afterwards. It turns out that this code tries to restore selection when filling char is restored even though the selection was in a different place of the anchor node at the moment of removing the filling char.

comment:4 Changed 4 years ago by Piotrek Koszuliński

Status: assignedreview

comment:5 Changed 4 years ago by Piotrek Koszuliński

Let's review this ticket in #12491, because I working on #12491 I found a case which wasn't even taken into consideration by branch:t/12489.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Fixed by #12491.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy