Opened 5 years ago

Closed 4 years ago

#12519 closed Bug (duplicate)

Having labels shown for menus includes "(Selected)" when the menu is open

Reported by: Thomas Jones Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version: 4.3
Keywords: Cc:

Description

This appears to have been introduced as part of http://dev.ckeditor.com/ticket/11331.

Our use case has a button with a menu that does not have an icon, but only has a text label. It is not a richcombo or anything like that, but makes use of a custom panel.

However, the only way to show the button label is via CSS, as shown in http://stackoverflow.com/questions/8486145/in-ckeditor-how-can-i-add-a-text-label-to-a-button.

Since the button plugin now adds "(Selected)" to the label when it's open, our toolbar gets thrown out of whack with the extra text.

Ideally, this wouldn't be done as an addition to the label, but through some attribute, but I understand the necessity for screen readers and accessibility.

However, we need some way to hide this label from the UI when we are showing the labels themselves.

The solution we currently have is to use

editor.lang.button.selectedLabel = '%1'

which is very, very hacky.

Change History (2)

comment:1 Changed 5 years ago by Jakub Ś

Status: newconfirmed
Version: 4.4.44.3

The same problem can be reproduced in HC mode as well.

comment:2 Changed 4 years ago by Marek Lewandowski

Resolution: duplicate
Status: confirmedclosed

I'll mark this ticket as a dup of #14237, even though it should be the other way around (this issue was reported earlier), just because have already started working on #14237.

You can follow it as it's targeted for 4.5.7 release.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy