Opened 5 years ago

Closed 5 years ago

#12548 closed Bug (invalid)

Inserting a page break hides all text after the break

Reported by: Jim Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I'm using CK editor to allow users to edit the content of a letter. The information is presented on a form in a simple text area.When the submit button is clicked, the page grabs the content of the text area and saves it in a mysql database.

Everything looks ok in the editor and is saved successfully to the database but, on re-opening the editor, everything after the page break is missing.

The html that was saved to the database still contains all of the text, including the page break code and another script that uses the HTML is able to display all of it. This script replaces any page break tags with custom tags and then renders the appropriate page.

Further Info

I've done a little bit of testing and the Page Break button seems to be omitting the closing <div> tag from the page break code that is inserted, resulting in :

<div style="page-break-after: always"><span style="display:none">&nbsp;</span>

*NOTE The missing closing <div> tag

Change History (4)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newpending

Everything looks ok in the editor and is saved successfully to the database but, on re-opening the editor, everything after the page break is missing.

Are you sure that the closing </div> tag isn't lost when saving the data to database or loading from it? For me everything works when loading data that contains:

<div style="page-break-after: always"><span style="display:none">&nbsp;</span></div>

If that's not a problem with the DB or your backend, can you paste here data that causes problem? And try to reproduce the same on http://ckeditor.com/demo#full. On what browsers does it happen? What setup do you use?

In other words - we need to be able to reproduce this issue and for us everything work just fine.

comment:2 Changed 5 years ago by Piotrek Koszuliński

Keywords: page-break removed
Version: 4.4.5

comment:3 Changed 5 years ago by Jim

Wow... it turns out that there was a line of code that seems to have removed just that one </div> tag.

Boy do I feel stupid!!!

Sorry to waste your time.

Last edited 5 years ago by Jim (previous) (diff)

comment:4 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

No problem. I'm glad you solved this problem.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy