Opened 4 years ago

Closed 4 years ago

#12627 closed Bug (invalid)

Ckeditor modify table cell border such as MS Word

Reported by: Moussi Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I need to apply border to single table cells. For that I built a plugin. My problem is, I can add a single border, e.g. border-bottom, but if I want to add border-right aswell, border-bottom gets deleted, and I only get the one border per cell.

I want to be able to add multiple borders to one cell. If i click again on e.g. border-bottom, only the border-bottom style should be deleted, and not the entire style.

I hope you cand help me out, it is very important for me.

you find in attached files the plugin.js file and screeeshot of the plugin

Attachments (2)

cellborder.PNG (18.9 KB) - added by Moussi 4 years ago.
Plugin screeshot
plugin.js (6.6 KB) - added by Moussi 4 years ago.
plugin.js

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by Moussi

Attachment: cellborder.PNG added

Plugin screeshot

Changed 4 years ago by Moussi

Attachment: plugin.js added

plugin.js

comment:1 Changed 4 years ago by Piotrek Koszuliński

Keywords: table cell border removed
Resolution: invalid
Status: newclosed

This is a bug tracker. AFAICS you're missing some features in some 3rd party plugin which is not a bug in CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy