Opened 4 years ago

Closed 4 years ago

#12672 closed Bug (duplicate)

Pasting several double byte whitespace copied from firefox shrinks them to one single byte whitespace

Reported by: Lukas Felber Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc:

Description

When copying 3 double byte whitespaces from Firefox and pasting them into a ckeditor field shrinks those 3 whitespaces to a single one. And that one is then a single byte whitespace (0x20) instead of a double byte whitespace (0x3000).

  • Steps to reproduce:
  1. create a html file with the following content:
    <html><title></title><body>
    x&#12288;&#12288;&#12288;x
    </body></html>
    
  2. Open the file in Firefox and copy exactly the 3 whitespaces (without the X).
  3. Paste into a ckeditor text field. (which browser does not seem to matter here)
  • Actual output:

One single byte whitespace (0x20)

  • Expected output:

Three double byte whitespaces (0x3000). Maybe it would also be acceptable to have 3 single byte whitespaces. But at least the number of characters should stay the same.

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

I was able to reproduce this problem from CKEditor 4.0 beta in Firefox and IE9-11.

Now, the result you talk about can be achieved when you pasted spaced next to existing text (same as in #12666). When you paste spaces into empty editor they get removed exactly as in #12666. Taking the above into account, I'm marking this ticket as duplicate of #12666.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy