Opened 4 years ago

Last modified 3 years ago

#12666 confirmed Bug

[IE9-11] Double-byte space disappears when pasting

Reported by: Lukas Felber Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: IBM IE Cc:

Description (last modified by Jakub Ś)

When copying multi-line text where each line starts with double byte white space(s) from Firefox and pasting into a ckeditor text field, the double byte white spaces are all dropped.

Steps to reproduce:

  1. create a html file with the following content:
    <html><title></title><body>
    &#12288;1<br>
    &#12288;&#12288;2<br>
    &#12288;&#12288;&#12288;3
    </body></html>
    
  2. Open the file in firefox and copy all 3 lines.
  3. Paste into a ckeditor text field (I'm currently using http://ckeditor.com/demo#inline for testing)

Actual behavior:
All double byte white spaces are dropped.

Expected behavior:
They should be retained.

Additional information:
If the same html file is opened in Chrome and copying happens from a Chrome browser, pasting into ckeditor text field succeeds as expected.

Change History (15)

comment:1 Changed 4 years ago by Lukas Felber

Keywords: IBM added

comment:2 Changed 4 years ago by Jakub Ś

Description: modified (diff)
Keywords: IE Firefox added

comment:3 Changed 4 years ago by Jakub Ś

Status: newconfirmed
Version: 4.0 Beta

I have been able to reproduce this prolem in IE9-11 and Firefox starting from CKEditor 4 beta.

I CKEditor 3.6.x as well as in native content editable element double byte spaces are preserved.

comment:4 Changed 4 years ago by Jakub Ś

#12672 was marked as duplicate.

comment:5 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Works fine with CKE 4.5.4 using: http://jsfiddle.net/96y5csy3/ and pasting into http://ckeditor.com/demo#inline

In my opinion it's been fixed in 4.5.0 because it can be reproduced on http://cdn.ckeditor.com/4.4.8/full-all/samples/replacebycode.html

comment:6 in reply to:  5 Changed 3 years ago by Satya Minnekanti

Replying to Reinmar:

Works fine with CKE 4.5.4 using: http://jsfiddle.net/96y5csy3/ and pasting into http://ckeditor.com/demo#inline

In my opinion it's been fixed in 4.5.0 because it can be reproduced on http://cdn.ckeditor.com/4.4.8/full-all/samples/replacebycode.html

@reinmar i could still reproduce this issue in IE11 on the link that you provided http://ckeditor.com/demo#inline Pls re-open it

comment:7 Changed 3 years ago by Marek Lewandowski

Resolution: fixed
Status: closedreopened

It's stil reproducible in IE11 if you:

  • copy from IE11
  • paste to CKEditor in IE11

When I've copied the source from Chrome and then pasted in IE11 it was working fine.

comment:8 Changed 3 years ago by Piotrek Koszuliński

When I've copied the source from Chrome and then pasted in IE11 it was working fine.

Then I presume that IE11 just doesn't copy those spaces (in this case we can't help with it).

comment:9 Changed 3 years ago by Jakub Ś

Status: reopenedconfirmed

comment:10 Changed 3 years ago by Piotrek Koszuliński

Turns out IE copies those spaces, but they are still lost somewhere. Perhaps somewhere inside the data processor or editor.insertHtml().

comment:11 Changed 3 years ago by Anna Tomanek

Summary: Double Byte White Space disappear when pasting from FirefoxDouble-byte space disappears when pasting

comment:12 Changed 3 years ago by Anna Tomanek

Keywords: Firefox removed
Summary: Double-byte space disappears when pastingDouble-byte space disappears when pasting in IE11

comment:13 Changed 3 years ago by Anna Tomanek

Summary: Double-byte space disappears when pasting in IE11Double-byte space disappears when pasting in IE9-11

comment:14 Changed 3 years ago by Anna Tomanek

Summary: Double-byte space disappears when pasting in IE9-11IE9-11 Double-byte space disappears when pasting

comment:15 Changed 3 years ago by Anna Tomanek

Summary: IE9-11 Double-byte space disappears when pasting[IE9-11] Double-byte space disappears when pasting
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy