Opened 4 years ago

Closed 4 years ago

#12692 closed Bug (duplicate)

Link Style background error

Reported by: Jack Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

When using the Link feature and adding background/background-image with a URL in the Style field, the user always gets this error:

"Value specified for the inline style must consist of one or more tuples with the format of "name : value", separated by semi-colons" http://screencast.com/t/fcDjtxTEHZ

Some examples of CSS added to get this error: background-image: url('https://dev.ckeditor.com/chrome/site/logo-ckeditor-dev.png'); background: url('https://dev.ckeditor.com/chrome/site/logo-ckeditor-dev.png');

Steps to produce: 1) Go to Link >> Advanced >> Style and add the following into the field: background-image: url('https://dev.ckeditor.com/chrome/site/logo-ckeditor-dev.png');

You can see these steps here: http://screencast.com/t/DG7UfcnTcmYL

Browser Used: Firefox v33.1

Cause of the Problem: I think this error shows because the URL contains a colon (':'), which is the basis of the name:value JS logic.

Need to update this so that background/background-image styles with URLs in do not get this error (currently only relative links can be added as background-image).

As shown in the screencast video above, managed to reproduce this on the nightly build.

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: Link Style Bug background background-image removed
Resolution: duplicate
Status: newclosed
Version: 4.5.0 (GitHub - major)

DUP of #12197.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy