Opened 4 years ago

Last modified 4 years ago

#12701 confirmed New Feature

Image2 could have limiter for resizing image to specified maximum,

Reported by: chen elisha Owned by:
Priority: Normal Milestone:
Component: General Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Jakub Ś)

Edit:
Image2 resize feature could have limiter which limits resizing image to:

  1. specified width (perhaps also height) in pixels.
  2. body (for classic editor) or editable element (for inline editor) width (perhaps height as well). I'm not sure whether size has to be specified or will be taken from computed styles (but what if body size changes in the meantime?)

image2 let you enlarge the picture beyond the editor limits so there is a horizontal-scroll if the image is too big

This is how HTML/CSS works. You can set overflow:hidden; for body element if you don't want to see scrolls. This is not a bug so I have reedited you original report.

Attachments (1)

bug.jpg (145.9 KB) - added by chen elisha 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by chen elisha

Attachment: bug.jpg added

comment:1 Changed 4 years ago by Jakub Ś

Description: modified (diff)
Resolution: invalid
Status: newclosed
Summary: image2 can resize beyond the ckeditor limitsImage2 could have limiter for resizing image to specified maximum,
Type: BugNew Feature
Version: 4.3 Beta

@chene i have changed your bug report to feature request.

comment:2 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: closedreopened

comment:3 Changed 4 years ago by Jakub Ś

Status: reopenedconfirmed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy