Opened 12 years ago

Closed 12 years ago

#1276 closed Bug (fixed)

Opera : Strange caret behavior when moving over a space

Reported by: Frederico Caldeira Knabben Owned by: Hallvord R. M. Steen (Opera Software)
Priority: Normal Milestone: Opera Compatibility
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Cc: Hallvord R. M. Steen (Opera Software)

Description

Steps to Reproduce

  1. Load sample01.html;
  2. Place the caret in the beginning of the text;
  3. Move the caret to the right with the keyboard until entering inside the "sample text" text. Pay special attention when moving over the space right before "sample".

Note that the caret will never blink between the "sample" and the space char right before of it. The strange thing is that the editing point will be moved there, even if the caret is blinking elsewhere.

It always happens for spaces that precede elements (it will happen right before the linked "FCKeditor" too).

Change History (2)

comment:1 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Owner: set to Hallvord R. M. Steen (Opera Software)
Status: newassigned

known issue, fix pending

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Works for me with Opera build 9660.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy