Opened 5 years ago

Closed 5 years ago

#12776 closed Bug (duplicate)

formatting (font, color etc.) is not inherited in new block

Reported by: Sergey Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Repro:

  • http://ckeditor.com/demo#full
  • remove all content
  • type "line1" in a new paragraph
  • select "line1" and set color of the selection to red
  • move cursor to the end of the line and hit enter
  • type some text
  • the new text on the 2nd paragraph is black
  • expected the new text to be in red, i.e. to inherit font color from the paragraph above where enter key was hit

Suspected code: https://github.com/ckeditor/ckeditor-dev/blob/a2468b6dfaa3fa5af6eda6d5dffcd971037f1798/plugins/enterkey/plugin.js#L367 if ( CKEDITOR.dtd.$removeEmpty[ element.getName() ] ) {

Should it be a negation of the condition above?

Change History (3)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newpending

I can't reproduce it. I checked Chrome and Firefox - on both, after pressing the enter and typing, the text is still colourful. I think that some detail may make the difference - could you record a screencast and describe how exactly you move the caret and on which browser does it happen? Please, also check on a different machine, because I remember that some browser addons or even antiviruses may affect the editor.

comment:2 Changed 5 years ago by Sergey

The screencast: https://www.screenr.com/l7qN

Repro steps:

  • open http://ckeditor.com/demo#full in FireFox 34.0.5 on Windows 7
  • select all text [Ctrl+A] and press [Del] to remove it
  • type "line1"
  • [Shift+Home] to select the new text
  • apply red color to the selection
  • [End] to move to the end of the line
  • [Enter] to insert a new paragraph
  • type "line2"
  • "line2" is in black color

Chrome appears to be fine with regards to the red color, but even after removing of all demo text the 1st line is still formatted as <h1>.

comment:3 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: pendingclosed

DUP of #3509.

Please see #8195 and #7796 for more details.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy