Opened 8 years ago

Closed 5 years ago

#8195 closed Bug (duplicate)

Moving in and out of element boundaries in Firefox

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox Cc: satya_minnekanti@…

Description (last modified by Jakub Ś)

This is the continuation or extension of #7796.

  1. Open replacebycode sample and clean both editors
  2. In first editor press bold button and type few words
  3. Go to second editor and type few words
  4. Go to first editor and click behind the text

Result: Bold button is no longer activated. It all depends whether Firefox decides whether you have left element boundaries or not.

After discussoin with @wwalc we have decided to create such ticket and link it to #7796 just to mark that this is not only about pasting.

Change History (8)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:3 Changed 7 years ago by Jakub Ś

Description: modified (diff)

comment:4 Changed 7 years ago by Jakub Ś

Another TC:

  1. Open replacebycode sample in Firefox
  2. Select sample text with a mouse
  3. Apply inline "Variable" style or "Cosmic Sans MS" font style
  4. Click behind the dot
  5. Path shows that you are no longer inside span tag.
  6. Press ENTER and start typing - inline style is not applied.
  7. Put cursor behind the dot, press LEFT_ARROW, press RIGHT_ARROW
  8. You should be behind the dot but this time in side VAR od SPAN tag.
  9. Press ENTER and start typing - styles are applied.
  10. It all depends whether Firefox decides whether you have left element boundaries or not.

comment:5 Changed 7 years ago by Jakub Ś

The same thing applies to font style, font-size, other format buttons and inline styles.

comment:6 Changed 6 years ago by Jakub Ś

#10560 was marked as duplicate.

comment:9 Changed 5 years ago by Jakub Ś

#11650 was marked as duplicate.

comment:10 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

It turns out this is a duplicate of #3509.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy