Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12817 closed Task (fixed)

Update copyright header

Reported by: Piotr Jasiun Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.4.7
Component: General Version:
Keywords: Cc:

Description

Because it is 2015 already header in all files need to be updated ("Copyright (c) 2003-2014" part).

Change History (5)

comment:1 Changed 4 years ago by Piotr Jasiun

Status: newconfirmed
Type: BugTask

comment:2 Changed 4 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:3 Changed 4 years ago by Olek Nowodziński

Status: assignedreview

branch:t/12817

grep -lr --exclude-dir={.git,node_modules} -e "2014, CKSource" . | xargs sed -i '' "s/2014, CKSource/2015, CKSource/g"

comment:4 Changed 4 years ago by Piotrek Koszuliński

You missed samples. This one is better:

grep -lr --exclude-dir={.git,node_modules} -e "2003-2014" . | xargs sed -i '' "s/2003-2014/2003-2015/g"

comment:5 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Actually, it's better to first run your, more precise pattern, committing and then my because the result of this one should be validated and if it would be executed first there would be 4k changed files to check :D.

Merged to master with git:9aa583c.

Last edited 4 years ago by Piotrek Koszuliński (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy