Opened 5 years ago

Closed 5 years ago

#12816 closed Bug (duplicate)

unable to write on text fields

Reported by: jonybigude Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version:
Keywords: Cc:

Description (last modified by Jakub Ś)

I have tried pretty much everything I could find on Google and I always come to a dead end (broken links) or to a solution that does not work. This is a very serious problem and I cannot understand how come this is still not solved!

I cannot edit/write text fields on ckeditor! I am loading ckeditor on a bootstrap modal. I have tried to load an old version of jquery - did not work, I tried to replace the whole ckeditor for an older version - did not work, I have tried to add z-indexes everywhere - did not work!! How can one fix this?

Please see comment:4 and comment:5 I am using bootstrap 2.3, jquery 1.7.1, modernizr and ckeditor 4.3.2

Change History (5)

comment:1 Changed 5 years ago by Piotrek Koszuliński

It's not solved, because it's not a bug in CKEditor. jQ UI modals as well as Bootstrap modals do some weird and very unsafe stuff with focus and break CKEditor's dialogs.

The only thing we can do is to document how to solve this issue using some hacks to stop Bootstrap/jQ UI from breaking focus. Unfortunately, we've never found time for that.

comment:2 Changed 5 years ago by Jakub Ś

Status: newpending
Version: 4.3.2

If you are talking about inserting e.g. textarea into editor content area and then typing inside it then you must know it is not possible to write directly inside form elements in editor editable area. This "functionality" was blocked and approach will not be changed. Typing inside form elements like text filed is only possible through CKEditor dialogs.


If you are talking about problems with typing inside dialogs when using jQuery then perhaps solution in one of tickets might help:
http://dev.ckeditor.com/ticket/5779#comment:8
http://dev.ckeditor.com/ticket/10081#comment:5 - for older jQuery/jquery UI
http://bugs.jqueryui.com/ticket/9087#comment:30 http://dev.ckeditor.com/ticket/12768 - for new jQuery/jQuery UI.


  • I think this issue is a duplicate of one of existing issues. @jonybigude please provide exact description of your problem.
  • Would it be possible to provide reduced working example? Something I could use on webserver with default editor and see the issue.
  • By the way, are you combining jQuery UI with Bootstrap or using only Bootstrap?

comment:3 Changed 5 years ago by Piotrek Koszuliński

By the way, are you combining jQuery UI with Bootstrap or using only Bootstrap?

I think that the report was about using Bootstrap modals, not jQ UI (which wasn't mentioned at all). And all your links are related to jQ UI.

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)

comment:4 Changed 5 years ago by jonybigude

I found the solution for this issue right after I posted this here. I found if by mistake actually. I could not find anything about this on CKEditor's documentation, perhaps it is a great idea to include it? Just sayin'...

Here comes the link to the solution: http://ckeditor.com/comment/127719#comment-127719

Thanks for your help in any case!

comment:5 Changed 5 years ago by Jakub Ś

Description: modified (diff)
Resolution: duplicate
Status: pendingclosed

I agree that this should be mentioned in documentation. You ticket however turned out to be a duplicate of #12525 thus I will have to close it.

I will however change this other ticket category to Docs and samples. Thank you.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy