Opened 4 years ago

Closed 3 years ago

#12848 closed Bug (fixed)

Opening "Find and Replace" dialog cause error in console in read only mode.

Reported by: Artur Delura Owned by: Tomasz Jakut
Priority: Normal Milestone: CKEditor 4.5.5
Component: General Version: 4.4.6
Keywords: Blink Cc:

Description

Browser: Opera, Chrome.

  1. Open "Read only" sample.
  2. Click "Make it read-only" button.
  3. Open "Find" dialog.

Error in console here.

Uncaught TypeError: Cannot read property 'clone' of undefined

Change History (7)

comment:1 Changed 3 years ago by Jakub Ś

Keywords: Blink added
Status: newconfirmed
Version: 4.4.6

Problem can be reproduced from CKEditor 4.4.6 in Blink browsers.

comment:2 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.5

comment:3 Changed 3 years ago by Tomasz Jakut

Owner: set to Tomasz Jakut
Status: confirmedassigned

comment:4 Changed 3 years ago by Tomasz Jakut

Status: assignedreview

Pushed fix to branch:t/12848.

comment:5 Changed 3 years ago by Marek Lewandowski

Status: reviewreview_failed
  1. Do we need all these plugins in the manual test? (see git:88836aef)
  2. Please check if test pass on all IEs (I can see that it passes at IE11 but fails at IE8)

comment:6 Changed 3 years ago by Tomasz Jakut

Status: review_failedreview
  1. No, we don't.
  2. The problem was in fact that editor was switched into read-only mode before inserting data into it.

Pushed changes to branch:t/12848

comment:7 Changed 3 years ago by Marek Lewandowski

Resolution: fixed
Status: reviewclosed

Fixed with git:9e566e1.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy