Opened 5 years ago

Closed 5 years ago

#12849 closed Bug (invalid)

SCAYT is undefined error in IE 11

Reported by: M Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi there.. I have a C# .Net web app. I have just upgraded from CKEditor v3.6.2 to v 4.6.4. When I load my web app I get the following error: "JavaScript runtime error: 'SCAYT' is undefined" on line on line 956 of ckeditor.js on this code

b=new SCAYT.CKSCAYT(b,
function(){},function(){})

I do not get this error in Firefox. Our production environment is moving to IE 11 soon.

Can you assist me?

Thanks Mike

Attachments (1)

build-config.js (3.2 KB) - added by M 5 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 years ago by M

FYI: The SCAYT feature was working using CKEditor v3.6.2

comment:2 Changed 5 years ago by Jakub Ś

Status: newpending

There is no version 4.6.4 yet. Did you meant 3.6.4 or 4.x ? Which CKEditor version you use exactly?

comment:3 Changed 5 years ago by Piotrek Koszuliński

Did you clear cache?

comment:4 Changed 5 years ago by M

Can you describe how I would do that, please? Thx

comment:5 Changed 5 years ago by M

Also, more helpful data. I don't receive the error in IE 8.0 but the Spell Checker doesn't work in IE 8 with CKEditor v4.6.4

comment:6 Changed 5 years ago by M

I just cleared the cache. Still having the same error.

comment:7 Changed 5 years ago by M

My bad. I just read your question regarding the version. It's v4.4.6 Apologies

comment:8 Changed 5 years ago by Jakub Ś

Ok, now that we got version and cache out of the way, please attach build-config.js file.

Additionally please tell me:

  1. if you have used one of predefined packages or perhaps have used builder to create CKEditor instance.
  1. Have you tried running standalone CKEditor on your server - does this error happen then or only when CKEditor is used with your application?
  1. Have you got any core code customization or CKEditor third-party plugins that might influence this behaviour? Perhaps you have made some extra plugin for SCAYT in your version 3.x?
  2. Finally have you got any custom plugins installed in your IE11? Any other spell checkers perhaps that might conflict with SCAYT?

Changed 5 years ago by M

Attachment: build-config.js added

comment:9 Changed 5 years ago by M

Thanks for the response:

1) I have attached build-config.js

2) I'm not sure what you mean by standalone CKEditor on the server. I opened samples/index.thml and it displayed fine. Is that what you were aksing?

3) We have modified contents.css but that's the only core component we have changed

4) There are no custom plugins to my knowledge. It's a standard IE 11 install that is division wide at our company. I have not added any plugins either.

comment:10 Changed 5 years ago by M

I attached config.js by accident. Could you delete that file? Thanks

comment:11 Changed 5 years ago by M

Another interesting clue. In config.js, the setting for

config.scayt_srcUrl = "http://<myServer>/spellcheck/lf/scayt/scayt.js";

is causing the error.

When I comment out that setting and leave the other two setting uncommented, the Spell Checker seems to work

config.scayt_autoStartup = true;
//config.scayt_srcUrl = "http://<MyServer>/spellcheck/lf/scayt/scayt.js";
config.wsc_customLoaderScript="http://<MyServer>/spellcheck/lf/22/js/wsc_fck2plugin.js";

Any ideas why?

comment:12 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

Perhaps you had a SCAYT server installed. In this case, please contact with http://www.webspellchecker.net/ team which provides this service.

I'm closing the issue as it was a configuration problem, not a bug.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy