Opened 4 years ago

Closed 4 years ago

#12850 closed Bug (fixed)

[IE QM] Error is thrown after focusing editor

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.4.7
Component: General Version: 4.4.6
Keywords: Cc:

Description

  1. Remove Doctype from one of the samples.
  2. Open it in IE9.
  3. Click in the editor.
  4. Error is thrown

Change History (4)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 4 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedreview

Pushed branch:t/12850.

Unfortunately I haven't found a way to stop Bender adding a doctype so I couldn't write a manual test.

While reviewing check FF QM, IE8 QM and IE9 QM with the following scenario:

  1. Remove doctype from the replacebycodesample.
  2. Open it.
  3. Verify that browse works in QM (in IE in dev tools and in FF in page info (CTRL+i)).
  4. Click inside the editor.
  5. Click new page.
  6. Click inside the editor again.

Error should not be thrown.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Actually, we should use a different check than using CKEDITOR.env, because we can sniff whether document supports old or new selection, but it's too late in the testing phase to make such change.

comment:4 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Fixed on master with git:fb00b8a.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy