Opened 4 years ago

Closed 4 years ago

#12851 closed Bug (fixed)

[Blink/Webkit] Formatting disappears when Ctrl+V pasting content into cells

Reported by: Aaron Dunfield Owned by:
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version: 4.0
Keywords: Cc:

Description

When I try and paste content from Notepad using Ctrl+V the formatting, in my case bolding of text, disappears. I have been able to reproduce this issue using the demo page of CKEditor. The Div Editing Area plugin (http://ckeditor.com/addon/divarea) must be used as well as the Chrome browser. I was unable to reproduce this issue using IE 10 or Firefox.

Steps to recreate issue.

  1. Insert a table and set width to 50%.
  2. Add some text and bold it.
  3. Click outside of the right side of the table.
  4. Press Delete key.
  5. Paste content using Ctrl+V.

Video: http://screencast.com/t/9pcKXBe02ff

Change History (2)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.0
Status: newconfirmed
Summary: Table formatting disappears when Ctrl+V pasting content into cells.[Blink/Webkit] Formatting disappears when Ctrl+V pasting content into cells
Version: 4.5.0 (GitHub - major)4.0

Wow... Another Blink/Webkit issue of the same nature as #9998. In short - the native implementation of contenteditable in Blink/Webkit is full of ugly issues like this one. We're constantly working on workarounding as many of them as possible. The good news here is that starting from CKEditor 4.5.0 we'll handle pasting in a totally custom way, so this issue should be fixed. I checked the major branch now and I couldn't reproduce this.

comment:2 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed by #11437.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy