Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12909 closed Bug (invalid)

Content filtering for inline styles, doc error

Reported by: Chris Graham Owned by:
Priority: Normal Milestone:
Component: Documentation & Samples Version:
Keywords: Cc:

Description

The docs says that setting allowedContent to true will disable content filtering.

However, this is not entirely true, you also need to set: extraAllowedContent : '*{*}'

I don't know why exactly, but I guess it is because your tag filtering, attribute filtering, and CSS style filtering, are all hooked in separately.

Regardless, the documentation needs to make it clear what exact filters run and how exactly to configure/disable each. Right now to me it is very clear that only setting allowedContent to true should be required.

Change History (2)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

However, this is not entirely true, you also need to set: extraAllowedContent : '*{*}'

That is not true. Setting allowedContent to true is enough to disable ACF. If you additionally set extraAllowedContent : '*{*}' it has no effect because ACF is disabled (you can’t define extra content for ACF when it doesn’t work).

comment:2 Changed 4 years ago by Chris Graham

Yeah, you're right, sorry. I narrowed it down to this issue yesterday, but it must have actually been some other kind of cache or state problem, because I couldn't go back and reproduce any problem at all today.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy