Opened 4 years ago

Closed 3 years ago

#12910 closed Bug (fixed)

Problems entering korean text in IE 11

Reported by: Younghwan Cho Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE11 Cc:

Description

I have problems entering Korean text in IE 11 browser. I'm not sure but it looks like same case with #10414 bug. please check it up and let me know what the problem is and how to fix it.

[Case]

If I enter rk(가), then sometimes the result shows rrk(ㄱ가) or disassembled characters(ㄱ ㅏ). You can reproduced this problem on your demo web site.

[Reproduce steps]

Steps to reproduce this issue. We use P entering mode

  1. Go to the ckeditor demo web page(http://ckeditor.com/demo)
  2. Delete all contents to make empty.
  3. I switch the language to Korean using IME.
  4. Type rk(가) and enter
  5. repeat step 4. 7 times more
  6. type rkskekfkakqktkdk(가나다라마바사아) --> total string length 64bytes until here
  7. enter and type rk(가)
  8. then the result shows rrk(ㄱ가) or disassembled characters(r k,ㄱㅏ)

I think that this issue is associated with string size. because if you followed reproduced steps, then total string buffer size will be 64 bytes. after that you entered and key in "rk" then the error comes out!

Attachments (1)

screen capture.mp4 (1.2 MB) - added by Younghwan Cho 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by Younghwan Cho

Attachment: screen capture.mp4 added

comment:1 Changed 4 years ago by Jakub Ś

Keywords: IE11 added; korean IE 11 removed
Status: newconfirmed
Version: 4.4.04.0

I don't think it is a duplicate. The TC is very different and reproducible every time.

I was able to reproduce this problem from CKEditor 4.0 (works fine in 4.0 beta).
From CKEditor 3.1 but if editor was working with IE11 in earlier versions it would be reproducible from CKEditor 3.0

Last edited 4 years ago by Jakub Ś (previous) (diff)

comment:2 in reply to:  1 ; Changed 4 years ago by Younghwan Cho

Replying to j.swiderski:

I don't think it is a duplicate. The TC is very different and reproducible every time.

I was able to reproduce this problem from CKEditor 4.0 (works fine in 4.0 beta).

If 4.0 beta version works fine then i will downgrade it.

How can I download it?

Last edited 4 years ago by Younghwan Cho (previous) (diff)

comment:3 in reply to:  2 Changed 4 years ago by Younghwan Cho

Replying to lguplus:

Replying to j.swiderski:

I don't think it is a duplicate. The TC is very different and reproducible every time.

I was able to reproduce this problem from CKEditor 4.0 (works fine in 4.0 beta).

If 4.0 beta version works fine then i will downgrade it.

How can I download it?


I found and try it. but unfortunately 4.0 beta version also has the same issue.

Last edited 4 years ago by Younghwan Cho (previous) (diff)

comment:4 Changed 4 years ago by Jakub Ś

Version: 4.03.0

CKEditor supports IE11 from version 4.3 so you can't downgrade.

Thanks for checking this issue - it seems I have made a mistake when reproducing (perhaps entered one Korean character less). Problem can be reproduced at least from CKEditor 3.1. Earlier versions would also have this issue.

comment:5 Changed 4 years ago by dlurrys

Can I follow this up? It doesn't seem to be solved only to be left. I am also using Ckeditor 4.5.4 and have the same issue above. What I find interesting is it works well in my former board(CKeditor 4.3) but it keeps having a problem when I use CKeditor 4.5.4. Is it related to #13377 so I can expect it to be updated in updated version 4.5.6?

comment:6 Changed 3 years ago by OYoung Kwon

After windows update (Nov, 2016), this problem fixed to me.

comment:7 Changed 3 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

@realkoy thak you for your comment. It looks like this issue has been fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy