Opened 4 years ago

Closed 4 years ago

#12965 closed New Feature (fixed)

Enhancements for Uploads Repository API

Reported by: Piotr Jasiun Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version:
Keywords: Cc:

Description (last modified by Piotr Jasiun)

Uploads Repository is missing some important methods:

  • repository.isFinished - returns true if all uploads are done,
  • repository.loaders - returns all loaders in upload repository.

It would be useful if one wants to block save button until all uploads are done.

Change History (7)

comment:1 Changed 4 years ago by Piotr Jasiun

Description: modified (diff)

comment:2 Changed 4 years ago by Piotr Jasiun

Status: newconfirmed

comment:3 Changed 4 years ago by Jonathan

This is a pretty important feature since large uploads may take a while.

comment:4 Changed 4 years ago by Piotrek Koszuliński

Summary: Uploads Repository APIEnhancements for Uploads Repository API

comment:5 Changed 4 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:6 Changed 4 years ago by Piotr Jasiun

Status: assignedreview

Done. Changes in t/12965.

Changes:

  • uploadRepository.loaders is now global; I can imagine some scenarios when user want to get all active uploads or all statuses; there is no reasone to keep it private;
  • introduced uploadRepository.isFinished and loader.isFinished; these methods could be very useful if user want to prevent some actions until all uploads are done;
  • removed uploadRepository.get; since loaders is global this method do nothing.

comment:7 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Merge to major with git:6fce1f8.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy