Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1301 closed Task (fixed)

Enable Opera compatibility

Reported by: Frederico Caldeira Knabben Owned by: Wiktor Walc
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version:
Keywords: Cc:

Description

Introducing the appropriate browser sniffing in the integration files to enable Opera 9.50 compatibility.

Generic rules for the user agent sniffing:

1# Check: Is Opera?

Check if "Opera/" is in UserAgent.

2# Check: Is compatible Opera version?

Get the number (including decimals) after "Opera/". It must be >= 9.50.

Change History (4)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

The JavaScript implementation has been introduced with [882].

comment:2 Changed 10 years ago by Wiktor Walc

Owner: set to Wiktor Walc
Status: newassigned

comment:3 Changed 10 years ago by Wiktor Walc

Resolution: fixed
Status: assignedclosed

Done with [886],[887],[888],[889],[890],[891],[897].

AFP version has not been tested yet because I couldn't integrate AFP on my computer neither with Apache 2 nor IIS 5.0...

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Sönke, our AFP maintainer, confirmed that the code is correct. He just pointed out that there could be issues with server configured to use commas for decimals separations. He proposed a solution... I've applied it with [907].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy