Opened 5 years ago

Closed 5 years ago

#13010 closed Bug (duplicate)

Text is not wrapped in the Source box - FF36

Reported by: Beruce Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

In Firefox 36 of the source text is not wrapped in the Source box of the CKEditor. It forms a horizontal scroll bar.

Change History (8)

comment:1 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

Please specify word-wrap : break-word; property for body in contents.css file.

Chrome adds this property as default while other browsers e.g. IE11, FF don't.

Writing non-breakable long words is not common case thus we will not be adding this to contents.css on our own.

comment:2 Changed 5 years ago by Beruce

This is nonsense! Up to version 35, it has made as Firefox Chrome: wrap lines and only a vertical scrollbar. The content.css is not suitable. The content.css does not affect the Source box. Please see the error again and do not constitute as quickly as wrong. best regards

comment:3 Changed 5 years ago by Jakub Ś

I don't understand what you mean but if you are trying to tell me that it has worked in previous versions of Firefox then all I can tell you is that we haven't done anything that affects this behaviour.

If we had it would work in previous versions of editor and it doesn't so this is clearly browser thing. The style I have mentioned works and should be used in contentcs.css in classic editor or HTML page CSS file for inline editor.

comment:4 Changed 5 years ago by Ivo Snabl

I agree with beruce, Firefox 36 change interpretation of style in skins/<yourskin>/editor.css: .cke_source { ... white-space:pre }

Add and override in your css file (not in content.css):

.cke_source {
  white-space: pre-wrap !important; 
}

comment:5 Changed 5 years ago by Jakub Ś

Thanks, I misunderstood @beruce. The break-word option works in wysiwyg area while @beruce was talking about source mode.

Fortunately other user has filed a ticket #13031 with link to Mozilla where everything is explained so the issue is valid we will have it fixed in next CKEditor release.

NOTE: let's leave this ticket closed and refer to #13031.

comment:6 Changed 5 years ago by Piotrek Koszuliński

This bug should not have been closed as invalid. It is a duplicate of #13031 which will be fixed in the next minor release.

comment:7 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: closedreopened

comment:8 Changed 5 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy