Opened 4 years ago

Closed 4 years ago

#13056 closed Task (fixed)

Plugin dependencies should be checked

Reported by: Wiktor Walc Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.5.0
Component: General Version: 4.5.0 Beta
Keywords: Cc:

Description (last modified by Wiktor Walc)

uploadimage requires clipboard to be loaded, but the clipboard plugin is not listed as a requirement:

https://github.com/ckeditor/ckeditor-dev/blob/major/plugins/uploadimage/plugin.js#L22

As a result CKEditor may not load. Might be worth to check other newly introduced plugins for similar issues.

There is a typo in the mentioned line as well ("lister")

Change History (7)

comment:1 Changed 4 years ago by Wiktor Walc

Description: modified (diff)
Status: newconfirmed

comment:2 Changed 4 years ago by Piotrek Koszuliński

Note: the notification plugin kind of requires the toolbar plugin, because without it there's no top space.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Type: BugTask

comment:4 Changed 4 years ago by Piotrek Koszuliński

It seems to be ok - uploadimage requires uploadwidget which requires clipboard.

comment:5 Changed 4 years ago by Wiktor Walc

Interesting, I'm quite sure I had error in that line and that listing all plugins manually did the trick, but indeed the requirements are fine. I'm okay with closing this ticket if requirements were checked for new plugins.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:7 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: assignedclosed

Fixed comment:2 and the mentioned typo with git:93d3318.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy