Opened 5 years ago

Closed 5 years ago

#13132 closed Bug (fixed)

[Adv. toolbar conf] The editor does not work in build version. Nothing happens on edit.

Reported by: Piotrek Koszuliński Owned by: Artur Delura
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version: 4.5.0 Beta
Keywords: Cc:

Description


Change History (7)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 5 years ago by Artur Delura

Owner: set to Artur Delura
Status: confirmedassigned

comment:3 Changed 5 years ago by Artur Delura

Do you have more information how to reproduce this issue? I built version using dev/builder/build.sh and changed editor address to ../../dev/builder/release/ckeditor/ckeditor.js in toolbar configurator index.html file.

comment:4 Changed 5 years ago by Piotrek Koszuliński

Why did you change editor address? Just check the samples that are in the dev/builder/release/ckeditor/samples folder.

comment:5 Changed 5 years ago by Artur Delura

The problem was caused by CKBuiler code minification. In here there is created a local variable CKEDITOR and then by using eval function into this variable is assigned editorConfig function and then executed. It breaks because minified code looks like:

(function() {
    eval(a);
    ({}).editorConfig(d);
    c = d
})();
Last edited 5 years ago by Artur Delura (previous) (diff)

comment:6 Changed 5 years ago by Artur Delura

Status: assignedreview

Changes in branch:t/13132.

comment:7 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Fixed on major with git:8b2157e.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy