Opened 4 years ago

Closed 3 years ago

#13143 closed Bug (fixed)

[Edge] Focus is lost when opening a color panel

Reported by: Piotrek Koszuliński Owned by: Tade0
Priority: Normal Milestone: CKEditor 4.5.2
Component: General Version: 4.5.0 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Follow up of #12858.

  1. Open any inline sample.
  2. Focus editor.
  3. Click the color button.
  4. Focus is lost (toolbar disappears).

It may not be a problem of inline editor only, because focus lost will not be visible in the classic editor.

Change History (13)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 4 years ago by Jakub Ś

Status: newpending

I think it works the same as in other browsers. Point 3 -> visible cursor is gone but (and it works the same everywhere)

Click on the color button, press Esc - cursor is back and you can write in editor.

Click on the color button, click on color button once more to hide it - cursor is gone for good.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:4 Changed 4 years ago by Piotrek Koszuliński

Kuba, you sure you tested Spartan? On none other browser toolbar is hidden (what indicates that focus is lost).

comment:5 Changed 4 years ago by Jakub Ś

Kuba, you sure you tested Spartan?

Thank you for putting so much faith into me ;) but stupid mistakes may happen so it is always worth to ask.

Yes I'm sure I have tested Spartan - Win 10 with IE12 the preview version. I have tested 4.4.7 and dev version.
In my case clicking on the color button doesn't hide the toolbar.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Yes I'm sure I have tested Spartan - Win 10 with IE12 the preview version

I'm asking because this is totally confusing. By default, even in the Win 10 technical preview, IE will work as IE11. Please read #12858's description if you haven't yet. You should be able to see "Edge" in the dev tools, not IE11. I want to be sure about this before we start checking what other differences we have (like - did you check latest major which changed a lot).

comment:7 Changed 4 years ago by Jakub Ś

Status: pendingconfirmed

(like - did you check latest major which changed a lot).

I have the edge not IE11 shown. I have double-checked it before testing. You have however pointed the right area. I have not checked latest major. I have checked latest master instead.

This issue can be reproduced in latest major. It doesn't occur in latest master or 4.4.7. I should have paid more attention to version you have selected.

comment:9 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.0CKEditor 4.5.1
Summary: [Spartan] Focus is lost when opening a color panel[Edge] Focus is lost when opening a color panel

We are still unable to work on such issues due to Edge's instability.

comment:10 Changed 3 years ago by Tade0

Owner: set to Tade0
Status: confirmedassigned

comment:11 Changed 3 years ago by Tade0

Status: assignedreview

Changes pushed to branch:t/13143.

Test mentioned in comment:8 are green both in Edge and IE11(Edge mode).

comment:12 Changed 3 years ago by Olek Nowodziński

Status: reviewreview_passed

comment:13 Changed 3 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

Merged git:f79b703 into master.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy