Opened 4 years ago

Closed 3 years ago

#13185 closed Bug (fixed)

[Toolbar configurator] Wrong position of the suggestion box if there is not enough space below caret.

Reported by: Piotr Jasiun Owned by: Artur Delura
Priority: Normal Milestone: CKEditor 4.5.0
Component: Toolbar Configurator Version: 4.5.0 Beta
Keywords: Cc:

Description (last modified by Piotr Jasiun)

On all browsers.

If there is not enough space in the viewport bellow the caret, the suggestion box is shown in the wrong position (should be directly above the caret).

Attachments (1)

Screenshot from 2015-04-14 11:52:59.png (146.8 KB) - added by Piotr Jasiun 4 years ago.

Download all attachments as: .zip

Change History (12)

Changed 4 years ago by Piotr Jasiun

comment:1 Changed 4 years ago by Piotr Jasiun

See attachment.

comment:2 Changed 4 years ago by Piotr Jasiun

Description: modified (diff)

comment:3 Changed 4 years ago by Jakub Ś

Status: newconfirmed

comment:4 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.0

comment:5 Changed 4 years ago by Artur Delura

Owner: set to Artur Delura
Status: confirmedassigned

comment:6 Changed 4 years ago by Artur Delura

Status: assignedreview

Changes in branch:t/13185. Please check, merge this issue before related ones and let me know, because it highly influence advanced toolbar behaviour. So I could check whether other issues won't break.

comment:7 Changed 4 years ago by Wiktor Walc

Component: GeneralToolbar Configurator

comment:8 Changed 4 years ago by Piotrek Koszuliński

Status: reviewreview_failed

After switching to the branch:

index.html:139 GET http://localhost/ckeditor-dev/samples/toolbarconfigurator/lib/codemirror/javascript.js
Last edited 4 years ago by Piotrek Koszuliński (previous) (diff)

comment:9 Changed 4 years ago by Piotrek Koszuliński

But besides that the issue is fixed.

comment:10 Changed 3 years ago by Artur Delura

Status: review_failedreview

Fixed this one and add yet recet version which is 5.2.

comment:11 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

It's still not perfect on some browsers (FF, IE8), but it's definitely better now. On FF and IE8 the panel is displayed below the caret even though there's not enough space, but we can live with this issue, because it's not actually that common. Most importantly - the panel is visible.

Fixed on major with git:27736b3.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy