Opened 4 years ago

Closed 4 years ago

#13186 closed Bug (fixed)

ACF not applied when paste event contains range

Reported by: Piotr Jasiun Owned by: Olek Nowodziński
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.5.0
Component: General Version: 4.5.0 Beta
Keywords: Cc:

Description

  1. Open http://tests.ckeditor.dev:1030/tests/plugins/clipboard/manual/draganddrop
  2. Select some blockquote or header.
  3. Drop it into the image caption.

Result: ACF is not applied, headers/blockquote are not stripped.

I checked that it is because of changes introduce in #13042: paste event contains range parameter when it is fired as a result of drag and drop. Without that parameter ACF works fine.

Change History (4)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.0
Priority: NormalHigh
Status: newconfirmed

comment:2 Changed 4 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:3 Changed 4 years ago by Olek Nowodziński

Status: assignedreview

Changes in branch:t/13186.

comment:4 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Great job! Nested editables are widget plugin's feature, so it makes sense to handle them there. In the same way we change the active filter when nested editable is focused - it also happens in the widget plugin.

Fixed on major with git:bca0002.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy