Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13196 closed Bug (invalid)

'too much recursion' while edit table content

Reported by: Michael Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I randomly get this two errors while i am edit content in a table:

too much recursion ckeditor.js:63:195 [Break On This Error]{return new CKEDITOR.dom.element(this.$.body)},getDocumentElement:function() too much recursion ckeditor.js:63:349

[Break On This Error]return new CKEDITOR.dom.window(this.$.parentWindow
this.$.defaultView)},write:function(a){this.$.open("text/html","replace");

When the Error happens the input is very slow, about 2 seconds for one character.

First i thought its happend because of the multiple CKEditor instances and / or the amount of text.

But it happens alsow with one instance and less text. My Version is 4.4.7 as the online demo. But i cannot reproduce this error on the demo page. Nevertheless i will ask you if you have an idea why this happpens ?

Here's an example of the HTML-Code which triggers the Error:

<table>
	<tbody>
		<tr>
			<td>
			<p>TesTest</p>
			</td>
			<td>
			<p>Was / Wann</p>
			</td>
			<td>
			<p>Bemerkung</p>
			</td>
		</tr>
		<tr>
			<td>
			<p>Kontrolle</p>
			</td>
			<td>
			<p>TesTest</p>

			<p>TesTest</p>
			</td>
			<td>
			<p>TesTest <em>Temperaturf</em>dadass</p>

			<p>(Datum, Visum,fffffasfffffffffffffasf<br />
			TesTest6 TesTestauf Abt.)</p>

			<p>Thermometer Bestell Nr. TesTest</p>
			</td>
		</tr>
		<tr>
			<td>&nbsp;</td>
			<td>
			<p>TesTest TesTestTesTest</p>

			<p>1x TesTest</p>
			</td>
			<td>
			<p><em>Protokollierung Reinigung</em></p>

			<p>Monatlich (Datum, Visum)</p>
			</td>
		</tr>
	</tbody>
</table>

Change History (5)

comment:1 Changed 4 years ago by Michael

Resolution: invalid
Status: newclosed

comment:2 Changed 4 years ago by Michael

closed, was not CkEditors fault

comment:3 Changed 4 years ago by Jakub Ś

Version: 4.4.7

Thanks for letting us know. We really appreciate such feedback.

Could you perhaps tell us what exactly was the problem in your case? Perhaps someone will have same or similar issue and will find a solution thanks to your explanation.

comment:4 Changed 4 years ago by Michael

Sure

Because of this http://dev.ckeditor.com/ticket/5479 someone implemented a part in our webapplication which checks if the content ends with "</table>". If so, "<br />" was added at the end. After this insert, an event from CKEditor was fired which checks if the HTML is correctly formatted. After this check the content ends again with "</table>". You see where it goes, our part again added the "<br />", again event fired.... And so on.

comment:5 Changed 4 years ago by Jakub Ś

Fortunately that problem no longer exists in CKEditor 4.x. When you insert table there is always P, DIV, or BR. If however for some reason there is no line behind the table you can use magic-line plugin - http://ckeditor.com/addon/magicline.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy