Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13229 closed Bug (invalid)

No way to scroll the editor's content on mac book

Reported by: heaven Owned by:
Priority: Normal Milestone:
Component: Core : Editable Version:
Keywords: Cc:

Description

When I scroll over the editor's content it scrolls the page instead, not the content.

The editor should grab all scroll events and should prevent page scroll even if the content is too small and has no scroll bar (or if scroll reached the end of the page). This at least should be configurable.

I can't reproduce this on the demo screen, this does work properly in the fullscreen mode.

Change History (4)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Status: newpending
Version: 4.4.6

I cannot reproduce it. Half of the CKEditor team use MacBooks and we haven't noticed anything like that. Note that CKEditor has nothing to do with scroll - it is not possible to affect it from JS. If something does not work it is most likely a browser bug.

Just to make sure - please tell us on what browser it happens. And we also need a sample on which the issue can be reproduced. There's a micro chance that it's something related to CKEditor, so it would great if we could see the issue.

comment:2 Changed 4 years ago by heaven

It happens in google chrome (42.0.2311.135 (64-bit)) and seems is somehow related to the layouting. I can reproduce only on a certain page and unfortunately this is a closed intranet CRM system so I can't show you. Does work well in FF.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

I'm sorry, but if we're not able to see and reproduce the issue we can't help you. I also don't think that CKEditor itself has anything to do with this issue, most likely it's Chrome's bug, so I'm closing this issue.

comment:4 Changed 4 years ago by heaven

Seems like that, sorry for the false report. If I ever find what was causing this I will add to this ticket. Thank you again.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy